www.messagexchange.com certificate issues

Incident Report for MessageXchange

Resolved

This incident has been resolved.
Posted Aug 22, 2025 - 09:31 AEST

Monitoring

We are aware of some clients having problems connecting to www.messagexchange.com since our certificate change this morning.

If you're having issues, please check that your certificate store is up to date. Normally this is done as part of your operating system's patches.

If not up to date, you may need to manually load the new Sectigo intermediate certificate - this included in our cert chain, available for download here:

https://support.messagexchange.com/support/solutions/articles/7000058245-www-messagexchange-com-certificate

Please contact Support if you need more information. support@messagexchange.com
Posted Aug 21, 2025 - 14:31 AEST
This incident affected: MessageXchange web site and Message processing.