MessageXchange: Forms issue
Incident Report for MessageXchange
Resolved
This incident has been resolved.
Posted Aug 19, 2019 - 12:55 AEST
Monitoring
The issue that was affecting some Forms functionality has been resolved. We are continuing to monitor the system. Please contact Support if you have any further issues.
Posted Aug 19, 2019 - 10:24 AEST
Investigating
We are investigating an issue affecting some Forms users, and will update with more information shortly.
Posted Aug 19, 2019 - 09:47 AEST
This incident affected: FormXchange.